A few questions

Problems with the Linux version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

A few questions

Postby Vadi » Sat Nov 24, 2007 2:57 am

Hi all,

Just finished the demo and really enjoyed the game. Before I make the purchase though, I had a few questions:

1) is it possible to select multiple units at once? I looked everywhere, but couldn't see how. I suspect it's in the game's design, but I don't quite understand the point if it then.

2) I'm on Ubuntu 7.10. Under the 'support' tab on the website, it says the latest patch is 1.5.11. In the changelog, the graphics improvements look really nice, however, the "Ported graphical engine from OpenGL to DirectX" line worries me as DirectX has no native support for Linux. So I guess that means I won't get that patch?

3) And lastly, under the 'problems with linux', it lists an even older patch, 1.3.0. Which is very confusing - I won't be able to even get the 1.42 patch either?

4) The demo makes it apparent that after you buy the game, you can just download it, no CD. However again in the linux section, it says that you need the Windows CD. Which is again confusing and conflicting information.

Can anyone clear me up on this please? Thank you :)
User avatar
xander
level5
level5
Posts: 16863
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Re: A few questions

Postby xander » Sat Nov 24, 2007 2:59 pm

Vadi wrote:1) is it possible to select multiple units at once? I looked everywhere, but couldn't see how. I suspect it's in the game's design, but I don't quite understand the point if it then.

No. You can only select/control one unit at a time (with a squad, consisting of several squaddies counting as one unit). As you can only have, at most, 5 controllable units on the map at any one time, I don't really see the issue with this restriction. There is never a time when you will need to control more than one unit at a time.

Vadi wrote:2) I'm on Ubuntu 7.10. Under the 'support' tab on the website, it says the latest patch is 1.5.11. In the changelog, the graphics improvements look really nice, however, the "Ported graphical engine from OpenGL to DirectX" line worries me as DirectX has no native support for Linux. So I guess that means I won't get that patch?

The newest patch was created in order to get the Games for Windows certification. Thus, the game had to be ported to DX10. The 1.5.x patch is for Windows only. We Mac and Linux users have been left out in the cold, to an extent, as IV are now working on Multiwinia and Subversion.

Vadi wrote:3) And lastly, under the 'problems with linux', it lists an even older patch, 1.3.0. Which is very confusing - I won't be able to even get the 1.42 patch either?

To my recollection, 1.3 is the latest released patch. However, there is a 1.4.x patch that has been in beta for a very long time. Check out the beta section of the forums, or maybe the Linux Issues section (I don't know where it is, right off, but you should be able to access and download that patch). As far as I know, the patch is complete, and ready for use, but is not in a "finalized" form yet.

Vadi wrote:4) The demo makes it apparent that after you buy the game, you can just download it, no CD. However again in the linux section, it says that you need the Windows CD. Which is again confusing and conflicting information.

You need the data that are on the Windows CD. You do not need the physical CD itself.

xander
Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

Postby Vadi » Sat Nov 24, 2007 5:57 pm

Ah okay, thank you for the reply. So I think I'm good then.

Quick question about Multiwinia - is there any word on the mac/linux version of it? And what do you mean by subversion - as far as I know, it's a revision control system (abbreviated as SVN).
User avatar
xander
level5
level5
Posts: 16863
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Sat Nov 24, 2007 7:02 pm

Vadi wrote:Ah okay, thank you for the reply. So I think I'm good then.

Quick question about Multiwinia - is there any word on the mac/linux version of it? And what do you mean by subversion - as far as I know, it's a revision control system (abbreviated as SVN).

I assume that there will be Mac and Linux versions of Multiwinia. As to Subversion, you are correct that it is a revision control system, but it is also the name of IV's "fourth" game (it looks as though Multiwinia will be released first, making Subversion the fifth game, but that is not how things are counted around here).

xander
Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

Postby Vadi » Sat Nov 24, 2007 8:06 pm

Okay, so I got the game. I downloaded the linux version, ran it, there was a garden level. I couldn't change my graphics settings for some reason (they simply wouldn't save), but I think I read a trick to fix that.

A question though, do I need the patch they describe here (http://www.darwinia.co.uk/support/linux.html), and how can I check what version of Darwinia have I got?
User avatar
xander
level5
level5
Posts: 16863
Joined: Thu Oct 21, 2004 11:41 pm
Location: Riverside, CA, USA
Contact:

Postby xander » Sat Nov 24, 2007 8:09 pm

If you just bought and downloaded the game from the IV store, then you should have the most recent version. As to finding the version that you have, it should be listed on the main menu of the game. Start the game. Hit [ESC] to bring up the main menu. It should be towards the bottom.

xander
Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

Postby Vadi » Sat Nov 24, 2007 8:24 pm

I did just buy & download it from the IV store, yeah. I don't see it in the main menu, but I saw it at the bottom of Other Options - it says linux full 1.2.1b. So I guess it's not the latest - I'll get the 1.4.2 patch.
Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

Postby Vadi » Sat Nov 24, 2007 8:26 pm

Uh. Where do I get the 1.4.2 patch? The link of "Linux users please click here to get patch 1.42." leads me to the 1.3.0 one...

:(
Vadi
level0
Posts: 8
Joined: Thu Nov 22, 2007 2:11 pm

Postby Vadi » Sat Nov 24, 2007 9:52 pm

Interestingly enough, I cannot use the support form either. Firefox keeps wanting to open the php script. I tried it on Konqueror, same thing. :?
estel
level4
level4
Posts: 689
Joined: Mon Jan 02, 2006 11:20 pm
Location: Bristol
Contact:

Postby estel » Mon Nov 26, 2007 6:03 am

For the patch, look no further than this forum, and in particular, this thread. The latest seems to be 1.4.0b9 (1.42 is the latest Linux Defcon version, iirc). There aren't that many changes :).

Return to “Linux Issues”

Who is online

Users browsing this forum: No registered users and 1 guest