Failed to set screen mode on win 7 netbook 1024x600

Problems with the Windows version of Darwinia

Moderators: bert_the_turtle, jelco, Chris, andy, John

markbond
level0
Posts: 1
Joined: Sat Jan 23, 2010 11:24 am

Failed to set screen mode on win 7 netbook 1024x600

Postby markbond » Sat Jan 23, 2010 11:31 am

trying to run a cd version of darwinia on a 1024x600 netbook and get the failed to set screen mode error. patch also fails to install as it says i need dx9 even though win7 has dx10. i guess the problem is my screen resolution, which cannot be increased. some people say to edit the preferences.txt but i do not have one as this is only created one first good run. can someone send me their prefs file? will this work? is there any other fix?


thanks :?
User avatar
Shwart!!
level5
level5
Posts: 1237
Joined: Sun Nov 12, 2006 1:36 am

Postby Shwart!! » Sat Jan 23, 2010 8:10 pm

1. Which patch are you talking about?
2. Have you tried setting the resolution from ingame? There is an options menu - press escape, go to options, then screen options. I'm not sure whether that specific resolution will be available or not, but if not, there should be several similar resolutions to choose from.
3. You should have a preferences file. The 'failed to set screen mode' error should just start Darwinia in a smaller, windowed resolution, so a preferences.ini file would be created. If Darwinia actually refuses to run, I'm not sure what to do about it. Can you clarify for me whether it actually starts or not?

Shwart!!
demagogue
level0
Posts: 1
Joined: Tue Mar 29, 2011 12:16 am
Location: D.C.

Postby demagogue » Tue Mar 29, 2011 12:31 am

I had this same error on my laptop.
I fixed it by running this program:
http://stellarmatter.net/static.php?page=dpg

I used DPG to create a preferences.txt file from scratch, with the screen resolution set to a lower value that my laptop could handle (like 800x600). Now it runs fine.

This should be put in the "Common Bugs" sticky because I saw the error coming up a lot in a Google search.
Zalminen
level0
Posts: 2
Joined: Thu Nov 24, 2011 5:06 pm

Postby Zalminen » Thu Nov 24, 2011 5:11 pm

Same problem here, and the DPG link just gives a 404 error now...

Anyone have a working preferences file?
User avatar
NeatNit
level5
level5
Posts: 2929
Joined: Mon Jan 28, 2008 2:41 pm
Location: Israel
Contact:

Postby NeatNit » Thu Nov 24, 2011 6:30 pm

I think you can just create a new preferences file with the following:

Code: Select all

ScreenWidth = 800
ScreenHeight = 600

It's really important that you have an empty line in the end of the file.

I haven't tested this but it couldn't hurt.
Zalminen
level0
Posts: 2
Joined: Thu Nov 24, 2011 5:06 pm

Postby Zalminen » Thu Nov 24, 2011 9:21 pm

Well, now the blackbox.txt showed it had read the preferences but it still gave me the same error.

Ah, installing the 1.5.11 patch did the trick (after I removed the preferences file again), should have tried that first :roll:
User avatar
NeatNit
level5
level5
Posts: 2929
Joined: Mon Jan 28, 2008 2:41 pm
Location: Israel
Contact:

Postby NeatNit » Thu Nov 24, 2011 10:19 pm

Didn't you buy it from the Humble Bundle? That should come with the latest update...


Whatever though, who am I to argue with results :P
SmaZz
level0
Posts: 1
Joined: Sun Nov 27, 2011 12:52 am

Solved

Postby SmaZz » Sun Nov 27, 2011 12:57 am

Lunch with
preferences.txt

Code: Select all

BypassNetwork = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = software
SoundMixFreq = 22050
SoundMasterVolume = 255
SoundChannels = 32
SoundHW3D = 0
SoundSwapStereo = 0
SoundMemoryUsage = 1
SoundBufferSize = 512
SoundDSP = 0
ScreenWidth = 1024
ScreenHeight = 600
ScreenWindowed = 0
ScreenZDepth = 24
ScreenColourDepth = 32
ScreenRefresh = 60
RenderLandscapeDetail = 4
RenderWaterDetail = 3
RenderBuildingDetail = 3
RenderEntityDetail = 3
RenderCloudDetail = 3
RenderPixelShader = 0
ControlMouseButtons = 3
ControlMethod = 1
RenderLandscapeMode = 1
ManuallyScaleTextures = 1
UserProfile = SmaZz
RenderSpecialLighting = 1
BootLoader = random

shiftkun
level0
Posts: 3
Joined: Sat Dec 03, 2011 11:48 pm
Location: United States

Re: Solved

Postby shiftkun » Sat Dec 03, 2011 11:50 pm

I did this, but then it gave me this

VERSION : win32-full-1.4.2
ERROR : 'Couldn't open language file language/english .txt'

Also, I have a netbook with WinXP. Same resolution as OP.

SmaZz wrote:Lunch with
preferences.txt

Code: Select all

BypassNetwork = 1
IAmAServer = 1
TextLanguage = english
TextSpeed = 15
HelpEnabled = 1
SoundLibrary = software
SoundMixFreq = 22050
SoundMasterVolume = 255
SoundChannels = 32
SoundHW3D = 0
SoundSwapStereo = 0
SoundMemoryUsage = 1
SoundBufferSize = 512
SoundDSP = 0
ScreenWidth = 1024
ScreenHeight = 600
ScreenWindowed = 0
ScreenZDepth = 24
ScreenColourDepth = 32
ScreenRefresh = 60
RenderLandscapeDetail = 4
RenderWaterDetail = 3
RenderBuildingDetail = 3
RenderEntityDetail = 3
RenderCloudDetail = 3
RenderPixelShader = 0
ControlMouseButtons = 3
ControlMethod = 1
RenderLandscapeMode = 1
ManuallyScaleTextures = 1
UserProfile = SmaZz
RenderSpecialLighting = 1
BootLoader = random


Return to “Windows Issues”

Who is online

Users browsing this forum: No registered users and 1 guest