Linux problems on DELL UBUNTU

Technical support for all issues relating to Defcon Linux

Moderator: Defcon moderators

genozzolo
level0
Posts: 5
Joined: Mon Mar 01, 2010 3:15 pm

Linux problems on DELL UBUNTU

Postby genozzolo » Mon Mar 01, 2010 3:18 pm

Hi

I cant play the game cause it crash, i found also the reason, the game push the temperature too high.

I think its a bug cause all other games, even FPS that ask much more performance doesnt give me any problem.

Any help why this temperature problem ?
genozzolo
level0
Posts: 5
Joined: Mon Mar 01, 2010 3:15 pm

Postby genozzolo » Mon Mar 01, 2010 3:20 pm

forgot, basically it close my laptop ( I think its the laptop security that turn off the pc cause too high temperature reached )

Then if i start the laptop it tell me that will be closed automatically cause too high temp has been reached and ive to wait 2-3 mins before start it again
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Mon Mar 01, 2010 3:40 pm

No, it's not a problem with the game. It uses OpenGL in a way that lets the system idle while it's waiting for the GPU to finish and for the screen to swap. The things it does, it does the way causing the least possible amount of heat. If that's overheating your system, it's not set up correctly or not specified to be used for games. There are several things you can try:
- enable VSYNC. On NVidia GPUs, you can do that by launching Defcon from the terminal with

Code: Select all

__GL_SYNC_TO_VBLANK=1 defcon

- reduce the screen resolution and detail Defcon uses.

What GPU/graphics chip do you have? And what's your precise Laptop model?
genozzolo
level0
Posts: 5
Joined: Mon Mar 01, 2010 3:15 pm

Postby genozzolo » Mon Mar 01, 2010 3:54 pm

Dell studio, bought 6 months ago.

ATI Radeon mobility 4500.

Americas Army, football manager, Quake3 , Counterstrike, and 2-3 fps latest with huge requirements that doesnt give me problems of temperature.

Defcon run very fluid , ofc it ask like nothing to cpu.

I can try GL_SYNC_TO_VBLANK=1 defcon also with ati ?
thanks for the reply
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Mon Mar 01, 2010 4:11 pm

Which studio exactly? It's a series.

And you can try, but the command is unlikely to work for ATI cards. Try the cacaclyst control center, it should have a checkbox. Also, while in Defcon, press F1 to get a frame rate counter. Only if it's above 60, enabling VSYNC will make your laptop run cooler.
genozzolo
level0
Posts: 5
Joined: Mon Mar 01, 2010 3:15 pm

Postby genozzolo » Mon Mar 01, 2010 4:43 pm

dell studio 15

4gb ram, cpu p8600 x2 @2400 mhz
genozzolo
level0
Posts: 5
Joined: Mon Mar 01, 2010 3:15 pm

Postby genozzolo » Mon Mar 01, 2010 4:50 pm

game runs at from 70 to 140 fps depend if theres action or not. I used the demo.
User avatar
bert_the_turtle
level5
level5
Posts: 4797
Joined: Fri Oct 13, 2006 6:11 pm
Location: Cologne
Contact:

Postby bert_the_turtle » Mon Mar 01, 2010 5:12 pm

Then VSYNC is definitely off and you should look for ways to enable it. It appears some ATI drivers/chips don't properly support it, you'll have to experiment a bit there.

On the hardware front, try googling 'dell studio 15 overheat'. It'll find some relevant hints, like how to clean your system from dust. That may help.
User avatar
Ace Rimmer
level5
level5
Posts: 10803
Joined: Thu Dec 07, 2006 9:46 pm
Location: The Multiverse

Postby Ace Rimmer » Mon Mar 01, 2010 5:26 pm

bert_the_turtle wrote:... like how to clean your system from dust. That may help.

Reminds me of

Karl wrote:[looking at lawnmower] It ain't got no gas in it.

Return to “Linux Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest